• Welcome to PlumbersLive.com - Please register for free, or login if you have an account here already. We have relaunched the forum with new forum software and a nice new feel to it. Find common questions related to Boilers, Central Heating, Gas Engineering, Water Plumbing, Bathroom and Kitchen Remodeling - all in our forums.

Ideal Logic Combi ES38 No control

Hello,

I have a Logic Combi ES38 Boiler and for some reason, it's ignoring the commands from the thermostats on the wall, for example, both thermostats are set to off but yet the boiler is still on, I've tried the following:
  • I've turned it to just water and not radiators no effect.
  • Changed the batteries in both there thermostats on the walls
  • Cleaned the connection pins on the thermostats.
  • Switched them on and manually tried changing the temperature.
If there is anything else I can try please let me know as I'm a bit confused why it's happening.
Its serviced every year and each time it's fine and like new so not sure if this is a fault or maybe its something that's worn out over time.

Cheers

WW
 
Had it on a three port valve ? What do you have fitted . Kop
2 circuits upstairs and downstairs , the upstairs is fine its the downstairs that seems to be going for it.

Photo on 05-04-2020 at 8.31 pm.jpg

Forgive me if I'm unsure of the lingo :S

Cheers
[automerge]1586115719[/automerge]
Both thermostats? Sounds like there is a two port valve somewhere that's giving a permanent live to the boiler.
Yes, I've set them both to be off, swapped them round, replaced the batteries but still for some reason is stuck on what I'm guessing / feels like 24
 
Last edited:
Top